
INTRODUCTION TO MULTIMEDIA DESIGN

Topic Objective:

 Define and explain the Photoshop Features

 Define and explain the CS3

 Define and explain the CS4

 Define and explain the Plugins

 Define and explain the Trademark

 Define and explain the Consumer market

 Define and explain the

Definition/Overview:

Adobe Photoshop: Adobe Photoshop, or simply Photoshop, is a graphics editing program

developed and published by Adobe Systems. It is the current and primary market leader for

commercial bitmap and image manipulation, and is the flagship product of Adobe Systems. It

has been described as "an industry standard for graphics professionals" and was one of the

early "killer applications" on the PC.

Adobe Photoshop CS4retails for $999, but a student license is available for $199. Adobe's

2005 "Creative Suite" rebranding led to Adobe Photoshop 8's renaming to Adobe Photoshop

CS. Thus, Adobe Photoshop CS4 is the 11th major release of Adobe Photoshop. The CS

rebranding also resulted in Adobe offering numerous software packages containing multiple

Adobe programs for a reduced price. Adobe Photoshop is included in most of Adobe's

Creative Suite offerings.

Key Points:

1. Features

This topic may contain original research or unverified claims. Please improve the article by

adding references. See the talk page for details. (November 2008)
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Further information: Comparison of raster graphics editors#Features

Photoshop has strong ties with other Adobe software for media editing, animation, and

authoring. Files in Photoshop's native format, .PSD, can be exported to and from Adobe

ImageReady, Adobe Illustrator, Adobe Premiere Pro, After Effects, and Adobe Encore to

make professional standard DVDs and provide non-linear editing and special effects services,

such as backgrounds, textures, and so on, for television, film, and the Web. For example,

Photoshop CS broadly supports making menus and buttons for DVDs. For .PSD files

exported as a menu or button, it only needs to have layers, nested in layer sets with a cuing

format, and Adobe Encore DVD reads them as buttons or menus. Photoshop is a pixel-based

image editor, unlike Adobe Illustrator, which is a vector-based image editor.

Photoshop can utilize the color models RGB, lab, CMYK, grayscale, binary bitmap, and

duotone. Photoshop has the ability to read and write raster and vector image formats such as

.EPS, .PNG, .GIF, .JPEG, and Fireworks. It also has several native file formats:

 The .PSD (Photoshop Document) format stores an image with support for most imaging

options available in Photoshop. These include layers with masks, color spaces, ICC profiles,

transparency, text, alpha channels and spot colors, clipping paths, and duotone settings. This

is in contrast to many other file formats (e.g. .EPS or .GIF) that restrict content to provide

streamlined, predictable functionality. Photoshop's popularity means that the .PSD format is

widely used, and it is supported to some extent by most competing software.

 The .PSB (Large Document Format) format is a newer version of .PSD designed for files

over 2 gigabytes.

 The .PDD (PhotoDeluxe Document) format is a version of .PSD that only supports the

features found in the discontinued PhotoDeluxe software.

2. CS3

Smart Layers display the filter without altering the original image (here on Mac OS X)

Photoshop CS3is marketed with three main components of improvement over previous

versions: "Work more productively, edit with unrivalled power, and composite with

breakthrough tools." New features propagating productivity include streamlined interface,

improved Camera Raw, better control over print options, enhanced PDF support, and better
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management with Adobe Bridge. Editing tools new to CS3 are the Clone Source palette and

nondestructive Smart Filters, and other features such as the Brightness/Contrast adjustment

and Vanishing Point module were enhanced. The Black and White adjustment option

improves users control over manual grayscale conversions with a dialog box similar to that of

Channel Mixer. Compositing is assisted with Photoshop's new Quick Selection and Refine

Edge tools and improved.. image stitching technology.

CS3Extended contains all features of CS3 plus tools for editing and importing some 3D

graphics file formats, enhancing video, and comprehensive image analysis tools, utilizing

MATLABintegration and DICOM file support.

3. CS4

Photoshop CS4features additions such as the ability to paint directly on 3D models, wrap 2D

images around 3D shapes, convert gradient maps to 3D objects, add depth to layers and text,

get print-quality output with the new ray-tracing rendering engine, and enjoy exporting to

supported common 3D formats; the new Adjustment and Mask Panels; Content-aware scaling

(also known as seam carving); Fluid Canvas Rotation and File display options. On 30 April,

Adobe released PhotoshopCS4 Extended, which includes all the same features of Adobe

Photoshop CS4 with the addition of capabilities for scientific imaging, 3D, and high end film

and video users. The successor to Photoshop CS3, Photoshop CS4, is the first 64-bit

Photoshop on consumer computers.

4. Plugins

Photoshop functionality can be extended by add-on programs called Photoshop pluginswhich

act like mini-editors that modify the image. The most common type are filter plugins that

provide various image effects. They are located in the 'Filter' menu.

5. Trademark

Adobe discourages use of "Photoshop" as a verb, as in using photoshoppingto refer to photo

editing, to prevent its trademark from becoming a genericized trademark. Nevertheless,

photoshopis commonly used as a verb. Also commonly shortened to "shopped", "chopped" or

"shooped", this has become the modern replacement of "airbrushed".

www.bsscommunitycollege.in   www.bssnewgeneration.in  www.bsslifeskillscollege.in

3
www.onlineeducation.bharatsevaksamaj.net        www.bssskillmission.in

WWW.BSSVE.IN



6. Consumer market

While Photoshop is the industry standard image editing program for professional raster

graphics and other digital art, its relatively high suggested retail price has led to a number of

competing graphics tools being made available at lower prices for the amateur market, such

as GIMP. To compete in this market, and to counter unusually high rates of piracy of its high

end products, the company introduced a consumer-oriented version of Photoshop as Adobe

Photoshop Elements. A more user-friendly interface and new tools such as the "red-eye"

reduction brush were aimed firmly at the more casual image editor. Many professional

features were omitted. Removing CMYK functionality, for example, made Elements

unsuitable for commercial prepress work.

Topic : Project 2: Learning Selection Techniques

Topic Objective:

 Define and explain the Explanation

 Define and explain the Data Source Abstraction

 Define and explain the Moving Selections (While Creating Them)

 Define and explain the Intersecting Selections

Definition/Overview:

Lasso Professional combines an interpreted programming language and server for developing

internet applications which use web browsers for the client user interface to connect to HTTP

and database servers. Lasso is developed by LassoSoft, LLC.
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Key Points:

1. Explanation

Lasso provides administration management over Lasso (via its internal users and groups) to

control explicit access permissions-based to data sources and language features to improve

security and data integrity in a multi-author web application development environment. Lasso

Server provides access to MySQL and numerous other databases via JDBCand ODBC, as

well as FileMaker Pro. Lasso Server runs on Mac OS X, Windows 2000, Windows 2003 and

Red Hat Linux.

Lasso's language, Lasso Dynamic Markup Language (LDML), can be written in a square

bracket tag format which resembles HTML, or in a LassoScript format similar to many other

scripting languages such as PHP, Perl, and Python. LDML can be written with procedural or

object oriented techniques and structures, and supports numerous data types including arrays

(indexed lists) and maps (name referenced lists).

Lasso is an extendable language. It currently includes the ImageMagick suite of image

manipulation tools, the ability to generate PDF documents and process and send email. Lasso

also includes broad support for industry standards such as XML, SOAP, WSDL,JSON, Java

EE, and Java Beans. Developers can extend Lasso by writing their own custom routines

which can be used and reused as custom tags or create new functionality via Java or the C

programming language to suit their needs.

2. Data Source Abstraction

The Lasso programming language provides developers the ability to create dynamic web sites

or applications with data source abstraction. The Lasso language allows the developer to

program in such a manner as to be independent of coding for a specific data source. This

allows files, sites and applications created with the Lasso language to be ported from data

source to data source with minimal or no changes. This level of abstraction is achieved by the

interpretive nature of the language.

Developers configure data sources within the Lasso administration system, setting

permissions, connection parameters and other relevant settings. They may also set an alias for

the data source, which allows for the abstraction.
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3. Moving Selections (While Creating Them)

Did you know that you can move a selection even while you are in the process of creating it?

The technique illustrated below is invaluable for creating precise shape selections.

 Use the Elliptical Marquee tool [M] (use [Shift+M] to cycle) to draw an approximate

selection (and hold the Shift key down as well to maintain a perfect circle). Don't worry about

where you start the selection

 With the left mouse button (and Shift key) held down, hold the Space Bar and (use the mouse

to) position the selection over the desired region

 Let go of the Space Bar (but not the mouse button (or the Shift key)) and continue sizing the

selection to encompass the region of interest

 Repeat Steps 2 - 3 until the entire object is contained within the selection (without ever letting

go of the left mouse button (and Shift key))

 Finally, let go of the mouse button (and the Shift key)

4. Intersecting Selections

You probably knew that you could add to the current selection by holding down the Shift

key, and subtract from the current selection by using the Alt key. But, did you know that you

could intersect selections by using both the Shift and Alt keys together?

There are several applications for this very useful technique, but for the purposes of this

example, we will keep it simple. After all, the point here is to learn, not to confuse you.

 Use the Elliptical Marquee tool [M] (use [Shift+M] to cycle) to draw an approximate

selection (and hold the Shift key down as well to maintain a perfect circle). Don't worry about

where you start the selection

 With the left mouse button (and Shift key) held down, hold the Space Bar and (use the mouse

to) position the selection over the desired region

 Let go of the Space Bar (but not the mouse button (or the Shift key)) and continue sizing the

selection to encompass the region of interest
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5. Selections By Subtraction

This selection tip is unique in that it is a somewhat "backward" way of isolating an object:

however, not only is it quick and easy, but it also works great on complex objects (provided

that they appear on a relatively consistent color background). To illustrate this technique, we

will use the smiley-face from the first tip (above), simply because it's so darn adorable.

 Use the Rectangular Marquee tool [M] (use [Shift+M] to cycle) to draw a selection which is

well outside the boundaries of the object you wish to isolate

 Choose the Magic Wand tool [W] and press Enter (Return) to display the Options palette

(Window Show Options). Confirm these settings: Tolerance =

 0, Anti-aliased = On, Use All layers = On, Contiguous = On. Now, with the Alt key held

down (subtraction mode), click on the background - inside of your selection, but outside of

your object

 Float the selection onto a separate layer [Ctrl+J] (Layer New Layer Via

 Copy)

In Section 2 of this course you will cover these topics:
Project 3: Working With Layers

Project 4: Painting And Using Color

Topic : Project 3: Working With Layers

Topic Objective:

 Define and explain the Selecting layers in the Layers palette

 Define and explain the Automatic Selections

 Define and explain the Layer Styles

 Define and explain the Transforming Layers
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 Define and explain the Deleting Layers

 Define and explain the Duplicating Layers

 Define and explain the Linking Layers

 Define and explain the Opacity

 Define and explain the Selecting Multiple Layers

 Define and explain the The Eyeballs: What They See Is What You Get

 Define and explain the Stacking Order

 Define and explain the Active Layer

 Define and explain the Adjustment Layers

 Define and explain the Fill Layers

Definition/Overview:

Creating Layers: Photoshop automatically creates the majority of the layers we need. A new

layer is added anytime you copy and paste an image or drag a layer between documents. If

youre starting from scratch, however, you can click the New Layer icon at the bottom of the

Layers palette to create a new, empty layer.

Key Points:

1. Selecting layers in the Layers palette

It is no doubt aware that you can select a single layer for editing by clicking it in the Layers

palette:

When you select a layer, its background goes a darker colour. If you select just one layer, it's

often called the active layer. Most Photoshop features, such as the painting tools, the

adjustments under Image> Adjustments, and the filters under the Filtermenu, work on the

active layer.

2. Active Layer

The layer youre currently working on will be highlighted in the Layers palette. To change the

active layer, just click the name of another layer. Or, if youd rather not use the Layers palette,

Command-click (Mac) or Ctrl-click (Windows) on your image while the Move tool is active.

That will cause the topmost layer that contains information under your cursor to become
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active. As you Command/Ctrl-click on different parts of your image (circle, square, triangle

in this example).

Watch the Layers palette to see which layer becomes active. Unlike previous versions,

Photoshop CS2 allows you to have more than one layer active at a time, but for now well

stick to working with one layer to keep things simple.

3. Stacking Order

You can change the stacking order of the layers by dragging the name of one layer above or

below the name of another layer in the Layers palette. The topmost layers can often obstruct

your view of the underlying images. To change this, you can reorder the layers by dragging

them up or down in the Layers palette.

4. The Eyeballs: What They See Is What You Get

The eyeballs in the Layers palette determine which layers will be visible in your document as

well as which ones will print. The eyeballs turn on and off in a toggle effect when you click

them: Now you see them, now you dont.

If you turn off all the eyeballs in the Layers palette, Photoshop will fill your screen with a

checkerboard. This checkerboard indicates that theres nothing visible in the document. (If

Photoshop filled your screen with white instead, you might assume that there was a layer

visible that was filled with white.) You can think of the checkerboard as the areas of the

document that are empty. When you view a single layer, the checkerboard indicates the

empty areas of that layer. As you turn on the other layers in the document, the checkerboard

is replaced with the information

containedon those layers. When multiple layers are visible, the checkerboard indicates where

the underlying image will not be obstructed by the elements on the visible layers.

5. Opacity

The Opacity setting at the top of the Layers palette controls the opacity of the active layer.

When this setting is lowered, the entire layer becomes partially transparent (transparent is the
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exact opposite of opaque). If you want to lower the opacity in a specific area instead of the

entire layer, you can lower the opacity of the Eraser tool and then brush across the area of the

layer you want to become more transparentthat is, unless the background is active. If you use

the Eraser tool on the background, it will simply paint with your background color instead of

truly deleting areas (remember, the background is always opaque).

6. Selecting Multiple Layers

With CS2, Adobe gave us the ability to make more than one layer active at a time. Clicking

on individual layers with no keys held will cause individual layers to be active. Command-

clicking (Mac) or Ctrl-clicking (Windows) on a layer will add that layer to the other layers

that are selected. Shift-clicking will select the range of layers that appears between the

layeryou Shift-clicked on and the one you clicked on previously. You can also Shift-

Command-click (Mac) or Shift-Ctrl-click (Windows) within an image while the Move tool is

active to add the layer that appears under your mouse to the layers that are currently selected.

There is no limit to the number of layers that can be selected at one time.

7. Linking Layers

When multiple layers are linked together, using the Move tool or choosing Edit > Transform

will cause the currently active layer and all the layers that are linked to it to change (as if all

the linked layers were selected). The advantage to linking layers is that the linking behavior

will be maintained regardless of which layer is active. So, if two layers should always relate

in size and position, link them together so that rerlationship will remain consistent. To link

multiple layers, select the layers and then click on the Link symbol thats found at the bottom

of the Layers palette. After linking the layers, moving or transforming the image while any

one of the linked layers are selected will cause all the linked layers to change. To unlink

layers, select the layers you want to unlink and click the link symbol again.

8. Duplicating Layers

To duplicate a layer, just drag the name of the layer onto the New-Layer icon at the bottom of

the Layers palette. This icon has two purposes: It will duplicate a layer if you drag one on top

of it, or it will create a new empty layer if you just click it. You can also hold Option (Mac)

or Alt (Windows) when dragging a layer up or down within the layers stack, or type
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Command-J (Mac) or Ctrl-J (Windows) to duplicate the currently active layer. Just make sure

you dont have a selection active; otherwise, this command will copy only the area that is

selected instead of the whole layer.

9. Deleting Layers

Layers can be deleted by dragging its name onto the Trash icon at the bottom of the Layers

palette or by Option-clicking (Mac) or Alt-clicking (Windows). Once you put something in

the trash, you cant get it back.

10. Transforming Layers

To rotate, scale, or distort the active layers, choose one of the options in the Edit > Transform

menu; then pull the handles to distort the image. When you like the way your image looks,

press the Enter key to commit to the change (press Esc to abort).

11. Layer Styles

Various options are available under the Layer > Layer Style menu. Youll find the same

options under the Layer Style pop-up menu at the bottom of the Layers palette (its the

leftmost icon). To experiment with these options, first create a new, empty layer, and paint on

it with any of the painting tools. Then apply one of the effects found in the Layer > Layer

Style menu: Drop Shadow, Inner Shadow, Inner Glow, Outer Glow, Bevel and Emboss, and

so on...I would suggest experimenting with these. Once you have at least one Layer Style

applied to a layer, youll see a black circle with a small f inside it in the Layers palette. Thats

the only indication that a layer has a Layer Style attached to it. You can click on the triangle

that appears next to that symbol to see a list of the Layer Styles that are applied to that layer.

If you drag one of the Layer Styles from that list and release your mouse button when its on

top of another layer, youll move that Layer Style to the second layer. Holding Option (Mac)

or Alt (Windows) when dragging a style will copy the style instead of moving it. Dragging

the word Effects will move all of the Layer Styles that are attached to that layer. If youd like

to remove one of the Layer Styles, just click on its name in the list and drag it to the Trash

icon at the bottom of the Layers palette.
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12. Adjustment Layers

The Adjustment Layer pop-up menu at the bottom of the Layers palette (its the half black and

half white circle) allows you to apply adjustments that will affect multiple layers. We will go

over this a little later in the semester.

13. Fill Layers

The options in the Layer > New Fill Layer menu allow you to add solid color, gradient, and

pattern content to a layer.

14. Automatic Selections

To select everything on a particular layer, just Command-click (Mac) or Ctrl-click

(Windows) on the thumbnail image of the layer in the Layers palette. If the layer fills the

entire screen, then it will select all because this trick looks for transparent areas. You can hold

down the Shift key to add to a selection that already exists, or use the Option key (Mac) or

Alt key (Windows) to take away from the current selection.

Topic : Project 4: Painting And Using Color

Topic Objective:

 Define and explain the Color It with PS Elements

 Define and explain the Make a Trial Run

 Define and explain the About Fuzziness

 Define and explain the Making the Selection

 Define and explain the Selecting Specific Colors

 Define and explain the Global Changes

 Define and explain the Components of a Color Management System

 Define and explain the Color Numbers, their Meaning and ICC Profiles
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Definition/Overview:

This project covers using painting tools and selecting colors. Areas covered include using the

Brushes palette, using color modes, selecting color, creating gradients, using the eraser tools,

and using the Pencil tool.

Resources include detailed information on color calibration, using ICC profiles, and how to

get consistent color results from Photoshop. Keep in mind that color management is primarily

intended for people in a pre-press environment. Not everyone needs it. If you're not doing

professional printing, try working without color management before you assume you need it.

If you're not happy with the results without it, these resources can help you fine-tune your

color settings so that what you see on your monitor is close to what you get from your printer.

Key Points:

1. Color It with PS Elements

One of the most frequent topics requested by readers revolves around changing or replacing a

color. We've had all kinds... clothing, cars, food, what have you. In the spring we always get

a rash of email asking how to change the color of various features of homes and gardens. This

January we had several requests for this technique in Photoshop Elements, both version 2 and

3. Sampling color is not new to the computer world; we've been doing it since the mid 1980s.

In this demonstration we'll show you two ways to do it -- both of which work well in either

version of Elements as well as in Photoshop. One method involves making a selection first,

and the other replaces all the chosen colors in the whole file. Although we prefer making the

selection, the second version is easier and works well -- but only so long as the color you're

replacing is not wide spread throughout the file.

For safety sake we'll work on a copy of the image. Drag the image in the Layers Palette and

drop it on the New Layer button to generate an exact copy to work on.

2. Make a Trial Run

Remember, one of the cardinal rules of these image editing programs is that when there's a

selection active the changes you make affect only the pixels contained within the selection. If

there's no selection, then the changes affect the entire layer or file.
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To demonstrate this, make a rough selection using the Lasso tool. If you wish to fine-tune

your selection, remember that holding the Option (Alt) key while making a new selection will

remove that portion from the existing selection. Likewise, holding the Shift key to the Lasso

tool will add the new selection to the existing selections.

Choose Enhance > Adjust Color > Replace Color

The resulting dialog offers three Eyedroppers, some sliders and a thumbnail mask of the

selected image. Use the Eyedropper to sample the color you wish to change. Since we

isolated the area to be acted upon with a selection, we can set the fuzziness of the selection

relatively high to get all the yellow color.

Now slide the Hue slider to make another color. We slid slightly to the left (-10 to -15) to get

a vivid cherry red. With Preview checked, you can see the color change affected only that

portion of the image contained in the Lasso selection. (Indicated by the "racing ants")

3. About Fuzziness

High Fuzziness settings will select more pixels related to the target color, and low settings

select less. If the setting is one (1) then you get only that pixel color you selected. Settings of

128 will actually encompass other colors in addition to the target color. We contained our

work area in a selection knowing that much of the wall in the background would contain

some of the more light pale yellow colors -- which needed to remain unchanged.

4. Making the Selection

Since we need to isolate the actions to just the car, we'll need a good selection.

We started out using the Magic Wand tool selecting the most predominate yellows. This gets

the selection started. Then using the Lasso Tool and the Shift key we added all the rest of the

car to be colorized.

Once the Selection was complete, we took the precaution of saving the Selection in case it

would be needed later. Choose Select > Save Selection (And name it)

5. Selecting Specific Colors

Now, with the selection still active, Choose Enhance> Adjust Color > Replace Color

anduse the Eyedropper with the Plus symbol (which adds to the colors selected with each

click) and click around in the yellow areas to select the colors to change. Again, you can

make your fuzziness settings relatively high; perhaps 32 to 64. Watch the thumbnail carefully

www.bsscommunitycollege.in   www.bssnewgeneration.in  www.bsslifeskillscollege.in

14
www.onlineeducation.bharatsevaksamaj.net        www.bssskillmission.in

WWW.BSSVE.IN



to make sure you get all the colors to be changed. Notice you can add ranges of color by

dragging the Eyedropper. Notice also, you can slide the Fuzziness slider and watch the effect

it has on the range of colors already selected. Slide the Hue slider to the desired color. Note

that in most instances you'll want to reduce the Saturation a bit, and perhaps move the

Lightness slider for a more realistic effect.

Flatten and use File > Save As... to rename and save the file.

6. Global Changes

Now, let's try the other method. Return to the original file and this time we'll use the

Fuzziness slider to bring in the color range for us.

Choose Layer> Duplicate Layer and hit Okay, or drag the Background layer to the New

Layer icon in the Layers palette to make your copy. One of the benefits of the Replace Color

function is that it's very forgiving - but we'll play it safe with the backup.

Choose Enhance> Adjust Color > Replace Color

In the Replace Color dialog box of Version 3 you can select Image option so that you see the

color thumbnail of the truck picture. Select the first Eyedropper and click an area of the color

you wish to change.

Now comes the fun. Drag the Fuzziness slider to the right and watch as more and more pixels

are changed. To test what you've learned, continue sliding it to the right and watch as other

parts of the image become affected. Now back off -- moving it back to the left until you reach

an acceptable compromise between the specific color replacement and any effect it may have

had on the background or other objects.

When you are satisfied with the results, click OK. Presto, cherry red hot rod. It's as easy as

that. If you're working on an image that has a lot of the target color scattered all around the

picture, you'll have to carefully select just those areas you wish to colorize. If you're using

Photoshop Elements version 3, you can also use the Color Replacement Brush hiding behind

the regular paint brush in the Tool Palette to paint on your color replacement.

Which ever way you choose to do it you can produce some pretty cool images with this

technique. If selecting a color for your house or car, just drag a new copy of the background,

and repeat the process with a different color change. Build up a collection of layers with

different color schemes so you can compare. It's easy and it's fun.
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7. Components of a Color Management System

A typical imaging system will consist of input and output devices, for example: scanners,

digital cameras, monitors, and printers. Unfortunately, with such a diverse range of device

types, technologies, and gamut limitations, it's inevitable that they will each reproduce the

same color differently (i.e. color is device dependent). Obviously, this will present significant

problems when working with documents originating from different sources, and will be

further complicated when the same document is destined for different types of output device.

Therefore, some means of ensuring that color data is reproduced in a predictable way

throughout the entire imaging system is essential. This is the purpose of a Color Management

System (CMS).

A color managed system comprises three basic components, namely: -

 A device-independent color space - this is usually referred to as the Working or Reference

color space.

 ICC profiles for each device (i.e. printer, scanner, monitor, digital camera, etc.) that will

accurately describe the unique color characteristics of each device.

 A Color Matching Module (CMM) that will interpret the information contained within the

device profiles and carry out the instructions on how the color characteristics of each device

should be treated.

8. Color Numbers, their Meaning and ICC Profiles

A digital image will usually comprise many millions pixels, each of which is represented by a

numeric value. The value assigned to each pixel will describe many attributes but in this

essay it's the color value or mix (e.g. RGB value) that we're most interested in. As I have

already mentioned, when a color is device-dependent, the appearance of pixels with identical

values will very often differ because each device has its own unique way of translating the

color "value" or "number" into visual color. The role of ICCprofiles is to ensure that

discrepancies that result from the widely differing color characteristics of each device are

known to the color management system. If we were discussing spoken language rather than

color, then the ICC profile would be synonymous with a translator.
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Device profiles come in two basic forms, i.e. Input and Output. Input profiles typically

describe the color characteristics of scanners and digital cameras, whereas Output profiles

describe devices such as monitors, printers and film recorders. Input profiles are often

referred to as one-way since they represent the source device. For obvious reasons we can

never convert a document into the color space of our scanner or digital camera. Output

profiles on the other hand are two-way meaning we can convert From or To them. For

example, we can convert a document with an embedded monitor profile into a document that

has a color profile describing a printer, or vice versa.

Consumer class film and flatbed scanner applications have been ICC aware for some time

now, with the vendors usually choosing sRGB as their preferred color space, which is a bit of

a misnomer because sRGB is not a device color space. Clearly, these vendors are doing some

work behind the scenes so as to keep things simple for the user, which isn't necessarily as

wise as it might first appear. The sRGB color space isnt generally regarded as appropriate for

high quality image editing, especially when print or film output is required. So, to overcome

this some vendors also provide the user with the option of choosing from a small selection of

alternatives. For example, printer vendors such as Epson provide generic ICC profiles with

their photo class printers, although its generally accepted these profiles are rarely as accurate

as users would like. Nevertheless, they are getting better with each new generation of printer.

As a rule, truly accurate color matching usually requires customised ICCprofiles for each

device and/or media type. These ICCprofiles can be created professionally or you can buy

your own profiling application.

In Section 3 of this course you will cover these topics:
Project 5: Using Type Elements

Topic : Project 5: Using Type Elements

Topic Objective:
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 Define and explain the Overview

 Define and explain the Adobe Premiere Elements

 Define and explain the Product history

Definition/Overview:

Adobe Photoshop Elements: Adobe Photoshop Elements is the consumer version of the

Adobe Photoshop raster image editing product, sold at a fraction (roughly 1/6th) of the cost

of the professional product. It contains most of the features of the professional version but

with fewer and simpler options. The program allows users to create, edit, organize and share

images, all from the same product.

Key Points:

1. Overview

Originally introduced alongside Photoshop version 7, Photoshop Elements targets

photography enthusiasts and thus lacks many features that make it useful in a proper print

production environment. For example, Photoshop Elements cannot export files in the CMYK

color mode, supports a simplified color management system, and excludes detailed soft-

proofing. It also either eliminates completely or offers simplified versions of some of the

more powerful plug-ins, along with a number of features aimed at non-experts (such as

removing the red-eye effect or changing the skin tone in a picture). An example of a

redesigned feature would be the Variations correction dialog. Some versions can, however,

open, edit, and save PDFs. Photoshop LE (Limited Edition) was Adobe's consumer raster

image editing product prior to the introduction of Elements. Photoshop LE had similar

limitations to Elements.

2. Adobe Premiere Elements

Adobe Premiere Elements is a video editing software application for non-linear video editing,

published by Adobe Systems. It is a scaled-down version of the professional-level Adobe

Premiere Pro, and is optionally bundled with Adobe Photoshop Elements. It is the number

one selling consumer video editing software. Its main competitors are Pinnacle Studio, Sony

Vegas Movie Studio, Corel VideoStudio, Final Cut Express and iMovie.
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Unlike many of its competitors, Premiere Elements can handle unlimited video and audio

tracks, with multiple keyframed effects applied to each clip, as well as Picture-in-picture and

chromakey capabilities. It also supports many third-party plug-ins for additional features,

including Premiere Pro plug-ins, After Effects plug-ins, and VSTeffects. It can create bars

and tone and a countdown leader, just like Premiere Pro.

This program also features real-time video rendering, unlike some other video editing

programs, which allows the user to instantly preview edits made to the timeline.

Premiere Elements is available for Windows XP and, beginning with version 3.0.2, for

Windows Vista.

3. Product history

 Adobe Premiere Elements 1.0 released September 2004. It was focused on consumer miniDV

camcorder owners who wanted to create DVDs.

 Adobe Premiere Elements 2.0 released September 2005. Adobe expanded video device

support beyond DV camcorders to include digital still cameras that capture video (MJPEG,

MPEG4, etc), DVD camcorders (.vob files), mobile phones (.3GP, .3G2, .MP4) and new

hybrid video devices like the JVC Everio and Everio G (.MOD). It also aimed to address the

lack of DVD configurability, one of the main criticisms of version 1. Unlike the first version,

PE2.0 may not work with AMD processors, or Intel processors that do not support the SSE2

instructions.

 Adobe Premiere Elements 3.0 released September 2006. Adobe added HDV support, stop

motion capture, audio narration, full-screen playback, and the ability to capture from WDM

sources (such as webcams and analog capture cards). This version improved ease of use by

adding Sceneline editing and allowing titles to be created and edited directly in the Monitor.

New export formats were added for mobile phones, iPods and PSPs. An updated 3.0.2

version was the first to support Windows Vista, although only Vista 32-bit.

 Adobe Premiere Elements 4.0 - released September 2007. Adobe added a SharingCenter, an

image stabilization filter and the ability to upload video files directly to YouTube. It also

includes more video effects and transitions, a slightly-modified user interface allowing

beginners to easily get started with the program (although it still retains unlimited video and

audio tracks), the ability to burn Blu-ray DVD discs, an audio mixer (like the version on

Premiere Pro) and movie themes similar to the ones from iMovie HD 6.
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 Adobe Premiere Elements 7.0 - released in October 2008, has been available for pre-order

since late August 2008. This version includes AVCHD support, an automatic movie-creation

wizard (similar to Pinnacle Studio's SmartMovie and iMovie HD 6's Magic iMovie), a built-

in SmartSound music generator (previous versions would only work with SmartSound via a

free plug-in downloaded from the SmartSound website), enhanced chroma-key technology,

among other features. It still retains the ease of use and prosumer-style technology of Adobe

Premiere Elements 4.

In Section 4 of this course you will cover these topics:
Project 6: Using Filters

Topic : Project 6: Using Filters

Topic Objective:

 Explain the Overview

 Explain the Bit map editing

 Explain the sheer number of filter effects can be bewildering.

 Explain the sheer number of filter effects can be bewildering.

 Explain the Convolution effects show the importance of contextual processing.

 Explain the Art filters are still based on a combination of blind mathematical operations.

 Explain the Corel Photo-Paint provides a more modern solution.

 Explain the Paint Shop Pro's Effect Browser lets you explore your filter options.

Definition/Overview:

Photoshop filters: Photoshop filters and plugins started to come on to the market in the early

90s. Early Photoshop filter sets included KPT Power Tools Volume 1, Andromeda, Aldus

Gallery Effects, Ring of Fire, Black Box plugins, and many others. Since then, Photoshop

filters have appeared in ever increasing numbers, and there are probably now 3000 or 4000

filters available, many of them are mentioned on this site. A wide variety of different filter
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plugin effects exist, from super professional and wacky-interfaced KPT Spheroid Designers

(from the legendary Kai Krause), all the way to more humble plugin (but still excellent)

creative tools such as the Filter Factory Filters.

Key Points:

1. Overview

A plugincan take many different forms: image processing, text, file formats, selections,

production filters, automation and more, but the most common is probably the special effect.

The special effect can take the form of simply shifting a pixel to the left or perhaps adding a

frame or a variety of frames or changing the color of a pixel or adding an emboss or fractal to

an image.

Pluginsare generally developed using the Adobe Photoshop SDK in Visual C++. Other

plugincreating tools exist such as the Filter Factory tool (which used to come supplied with

Photoshop) and the Filtermeister plugin. The end result of the creation of the plugin is a .dll

that can be loaded upon startup by Photoshop or other application. If the application and the

plugin fully support the Photoshop pluginsformat, the plugin will work in basically the same

way in all applications though as with all things, the format and the host applications are

always changing and so not all pluginssupport automation or actions say (even now).

Many applications have their own native plugins and these are generally not swappable

between applications. Each application offers its own unique take on a plugin effect or might

offer additional effects not found in any available pluginset.

2. Bit map editing

The most common task in bitmap editing is enhancing your photo's existing qualities through

colour correction and image adjustment. The most creative option lies in treating your

starting image as just that: a jumping off-point to wherever your imagination and your photo

editor's capabilities can take you. When you go down this route you're inevitably going to be

drawn towards your application's bitmap filters and, whichever application you use, you'll

find no shortage of creative power available.

In fact the sheer range of power on offer can be overwhelming. With dozens of effects from

Accented Edges through to ZigZag, the big danger is that you'll suffer from filter fatigue
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before you've even begun. Even worse, the variety within each collection is so huge, ranging

from simple one-off commands through to virtual mini-applications, that it's difficult to see

what can possibly connect them. After a few minutes' exploration most users are left

wondering just what a filter actually is.

3. The sheer number of filter effects can be bewildering.

To understand this, you have to remember that each image is a bitmap - a grid of pixel values.

Bearing this in mind, it's clear that each filter works as a black box taking one set of pixel

values and returning another. It's an idea that we're used to from colour-correcting image

adjustments where colour values are consistently mapped from source to destination.

However you only have to compare, say, a creative artistic watercolour filter effect to a

levels-based adjustment to realize that there are also core differences. Each filter might be a

black box, but the big question is what happens within the black box?

To get a handle on what makes a filter tick and what makes it different, it's useful to create

your own. This is possible using Photoshop's Filter>Other>Custom, Photo-

Paint's>Effects>Custom>User-Defined and Paint Shop Pro's Effects>User-Defined

commands. In each case what you are presented with is a customizable matrix centredon the

current pixel being processed and into which you enter values. The filter then applies what's

known as a "convolution" to the matrix. Effectively all the pixel colour values are multiplied

by the values you've entered in the cells and summed and this sum is then used as the output

value for the central pixel and this is repeated for each pixel in the image.

Unless you make sure that the sum of the values you enter into the matrix is close to one, the

image will quickly turn toward white or black, but within this constraint you can produce

some eye-catching results. The Custom filter's convolution effect isn't often useful in

practice, but it is useful for what it shows about filters in general. In particular it shows how

each pixel is reassigned a value based on the values of surrounding pixels. This is very

different to a colour correction adjustment where every pixel is treated independently and

every pixel with the same colourvalues is treated equally wherever it appears. With a filter,

context is all.
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4. The sheer number of filter effects can be bewildering.

To understand this, you have to remember that each image is a bitmap - a grid of pixel values.

Bearing this in mind, it's clear that each filter works as a black box taking one set of pixel

values and returning another. It's an idea that we're used to from colour-correcting image

adjustments where colour values are consistently mapped from source to destination.

However you only have to compare, say, a creative artistic watercolour filter effect to a

levels-based adjustment to realize that there are also core differences. Each filter might be a

black box, but the big question is what happens within the black box?

To get a handle on what makes a filter tick and what makes it different, it's useful to create

your own. This is possible using Photoshop's Filter>Other>Custom, Photo-

Paint's>Effects>Custom>User-Defined and Paint Shop Pro's Effects>User-Defined

commands. In each case what you are presented with is a customizable matrix centredon the

current pixel being processed and into which you enter values. The filter then applies what's

known as a "convolution" to the matrix. Effectively all the pixel colour values are multiplied

by the values you've entered in the cells and summed and this sum is then used as the output

value for the central pixel and this is repeated for each pixel in the image.

Unless you make sure that the sum of the values you enter into the matrix is close to one, the

image will quickly turn toward white or black, but within this constraint you can produce

some eye-catching results. The Custom filter's convolution effect isn't often useful in

practice, but it is useful for what it shows about filters in general. In particular it shows how

each pixel is reassigned a value based on the values of surrounding pixels. This is very

different to a colour correction adjustment where every pixel is treated independently and

every pixel with the same colourvalues is treated equally wherever it appears. With a filter,

context is all.

5. Convolution effects show the importance of contextual processing.

This contextual processing can immediately be put to good use in two important areas

blurring and sharpening. By comparing a pixels values to those of its surrounding pixels you

can then change its values accordingly. By lowering the contrast between adjacent pixels the

image loses sharpness; by increasing it, the image comes into focus. When Blur and Sharpen

filters were first introduced they were crude fixed commands, but the filters and their results

can be made more flexible and effective by introducing conditional processing so that, for
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example, a Sharpen Edges filter will only apply its effect if the existing tonal variation is

already greater than a given threshold.

The Blur and Sharpen filters (and especially the Gaussian Blur and UnsharpMasking

variations) are the most fundamental of filters and, by subtly enhancing the quality already

there in your photos,they can prove just as useful as the main colour correction commands.

Alternatively, the same underlying principle of identifying and manipulating tonal ranges can

be used to produce very different results. By identifying small islands of isolated

colourvalues often introduced when scanning an image a Remove Noise or Dust and

Scratches filter can then replace them with an averaged value from surrounding pixels. A

Find Edges filter, on the other hand, can remove all the colour information that doesnt differ

strongly from its neighbours.

Rather than identifying edges and difference, filters can also be used to recognize areas of flat

colour and similarity. With a Crystallize or Facet filter, for example, the image is broken up

into cells and these are then averaged. Different cell shapes and sizes produce totally different

results while introducing a coloured border between cells can produce Pointillist, Mosaic and

Stained Glass effects. More advanced filters, such as a Silk Screen effect, are less rigid and

more trueto the original producing more artistic almost hand-produced results.

It might not seem that significant but breaking the image down into regions for processing

like this reveals another important aspect of filters and another difference to colour correction

adjustments each pixels processing can depend on its position in the image. In fact there are a

whole host of filters where this is the major factor. From the simple tile-based displacement

Puzzle effects through an almost infinite range of Twist, Pinch, Skew, Punch, Ripple and

Twirl distortion effects to the most advanced, interactive Liquify manipulations each of these

filters works by mapping original co-ordinates to target co-ordinates. The same is true of

another important category of filter, the 3D effects such as Spherize, Cylinder and 3D

Transform which work by mapping pseudo-3D manipulations back onto the 2D target

bitmap.

Another crucial difference between colour correction enhancements and filters is that the

former work purely with the information that is already there in the image. With filters this

isnt a restriction so that external pixel information can be brought into the equation. This is

most obvious with texture filters that can be used to apply fills based on seamlessly tiling

textures to create wood, brick, grass effects and so on. By blending the texture information

into the existing pixel values more subtly, surface effect filters can make it seem as if the

image is printed or painted onto canvas.
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Rather than relying on existing bitmaps, the external pixel values can be generated from

scratch. There are a whole host of filters for adding mathematically generated fills, fractals,

clouds and advanced gradients. Lighting effects can also be seen as another form of external

pixel information that is realistically and seamlessly blended into the existing image by

interacting with the existing colour values. And why just add patterns? There are also filters

designed to add recognizable objects such as realistic clouds, fireworks, lightning, snow and

so on.

6. Art filters are still based on a combination of blind mathematical operations.

In fact of course weve already seen the answer or rather answers. Each of the art filters works

on the same principles that weve already seen identifying and applying colour blocks and

outlines, blurring and sharpening, distorting and displacing, applying textures as paint strokes

and other textures as canvas materials and so on. There isnt a ghost or in this case artist in the

machine. The results of the art filters might be beautiful but ultimately they come down to

brute mathsin just the same way as the crude convolution effects. Compared to the relatively

simple mapping of a colour-correcting image adjustment, an artistic filter involves complex,

contextual and conditional processing but essentially it all boils down to the same thing:

number crunching with a purpose

So far weve explored how filters work and along the way seen just what sort of work they can

achieve. Now lets look at just what filter-based power each of the main bitmap editors

provides.

Inevitably most attention focuses on the market leader Photoshop especially as over its long

life it has built up a collection of just under a hundred filters. Theres no doubting the range of

power but its difficult to feel on top of the filters as they, and the 13 categories into which

theyve been organized Artistic, Blur, Brush Strokes, Distort, Noise, Pixelate, Render,

Sharpen, Sketch, Stylize, Texture, Video, Other have evolved over time and seem fairly

random. The artistic effects, for example, have been split into three categories though many

would fit just as well under any heading. And I dont suppose that there are many users who

can tell what effect the Reticulation or Sumi-e filters will produce before applying them.

When you do apply a filter, you are immediately reminded of just how old and idiosyncratic

many of these filters are. The dialogs tend to be small with just two or three mysterious

parameters that produce unpredictable results when changed and sometimes the end results

are actually dependent on external factors such as your current foreground and background

colours. That wouldnt matter if the dialog told you as much, but theres no information on
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what effects can be achieved or how and theres no direct access to the online help to find out.

Theres also no Reset button to restore the default settings (though one does appear if you hold

down the Alt key!)

7. Corel Photo-Paint provides a more modern solution.

Each filters dialog also seems much more modern partly because they are based on the

normal Windows look-and-feel, but also because more effort has been put into making them

transparent and consistent. Other improvements include a direct link to the online help for

each dialog, a Reset button and the ability to swap filters (and adjustments) from a fly-out

menu without having to close and reopen the dialog. What really makes the difference though

is that each dialog offers three ways of working: with a large inbuilt 1:1 preview; with

smaller before and after previews; or live on the current image.

By comparison, Paint Shop Pro (PSP) just falls under the hundred mark with its range of

filters, but I particularly like their arrangement. Rather than settling for a purely alphabetical

approach the range of categories are sensibly divided into core effects Blur, Sharpen, Edge,

Noise, Enhance Photo followed by creative effects 3D, Artistic, Geometric, Illumination,

Reflection and Texture.

Within each dialog, Paint Shop Pro offers a Reset button and quick access to detailed help

and also offers enhanced preview capabilities with in-built Before and After windows, and

options to either preview the current settings on the full image or to automatically proof all

changes as you make them. Its just a pity that the power is rather let down by PSPs ugly

shareware look-and-feel and by a tendency to over-complicate matters.

PSP also offers another welcome innovation in the form of the Effects Preview that lets you

see the default settings of each effect applied to a reasonably large preview thumbnail. Its not

an accurate reflection of the final result but it does give enough of an idea of the effect to help

you decide whether to open the filter. The downside is that each preview is generated one at a

time as you work your way through the list so that exploring all 97 filters isnt really an

option.
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8. Paint Shop Pros Effect Browser lets you explore your filter options.

Finally theres PhotoImpact. This offers a smaller range of 67 filters under its Effects menu

arranged into ten categories Blur, Sharpen, Noise, Photographic, Distort, Illumination,

Artistic, Video, Creative and Material Effect. Many of the filters are comparatively crude and

their dialogs are less than helpful. Open the Watercolour effect, say, and you are presented

with nine tiny preview options that are much too small and inaccurate to base any sensible

decision on, while clicking on the Advanced option leads to a very rudimentary set of

controls. Open another filter such as Painting or Particle, however and the opposite is true.

Here you are presented with a bewildering host of presets and parameters the power is

unquestionable but its difficult to know where to begin to try and produce a particular effect.

If this mixed bag was all that PhotoImpact offered it wouldnt be a contender, but the program

has an important trick up its sleeve. Rather than calling up the relevant filter dialog through

the Effects menu commands, the most common way that effects are applied is through the

many galleries in the EasyPalette. This makes a huge difference. Because all effects are

represented by thumbnails you dont have to know what effect, say, the Craquelure filter will

have you can see it. And, unlike with Paint Shop Pros Effects Preview, you can see alleffects

within a given category.

To then apply the effect with the default settings all you have to do is double-click on the

thumbnail. If you dont like the result you can simply undo it and choose another. If the filter

needs fine-tuning, you can right-click on the preview thumbnail and select the Modify

Properties command to call up the associated filter dialog. And if you do call up the dialog

for fine-tuning you can save your settings as a new thumbnail to be applied in future. In fact

PhotoImpact has taken this approach itself to provide literally hundreds of preset effects

based on its main filter engines.

In Section 5 of this course you will cover these topics:
Project 7: Photoshop And The Web

Project 8: Printing And Publishing
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Topic : Project 7: Photoshop And The Web

Topic Objective:

 Define and explain the Photoshop in web Designing

Definition/Overview:

The Photoshop Web Reference is designed to be the definitive online source for information

on Adobe Photoshop. Just about everything you'd ever want to know about PShopis here, in

one place. Please select either version 4 or version 3.

Key Points:

1. Photoshop in web Designing

Photoshop is the most commonly used worldwide tool for designing optimised websites. This

product from Adobe is a boon to graphic and web designers. It has proved its importance and

efficacy in handling images as it has emerged as the right hand of the designers. With the

help of Photoshop pro, the World Wide Web designers are able to manipulate .gif, .jpeg and

.png files and so on. With advancements in software, Photoshop has emerged as the unbeaten

software of its kind. This graphics editing software is compatible with both Microsoft

Windows and Mac OS X.

A website has to be pleasant and admirable. Then only will it stay longer in the minds of the

visitors. Among millions of websites being visited by millions of surfers every day, the

effective use of Photoshop would definitely bring in good response from the users. The

specialty about it is that it can help designers in every aspect of web site design and

promotion. The perfect link of Adobe Photoshop with other products of Adobe has made it

triumphant as a graphics editor. When talking about all aspects, it can be perfect as website

design, animation and every other possible website promotional graphics can be done with

Photoshop.

To be a competing graphics editing software, designers can work with many colour forms to

bring out perfect design suited to mood and need. A few to mention Photoshops efficiency
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are RGB colourmodel, Lab color model, CMYK colourmodel, Greyscale and Duotone. The

most commonly used colour form for web designing in Photoshop is the RGB colour model.

The colour combinations of RGB colour models have no problem in viewing the colours on

the web. The second option, Lab colour, has possibilities of using coloursthat do not exist in

the real world and it has more colouroptions than RGB colour. It also has more colour ranges

beyond RGB colour form. CMYK brings out absolute resolution of colouredimages while

printing. The Photoshop designed brochure or any printing material comes out perfect when

this colour model is used.

Another vital reason for Photoshop being the King of image editing software other than

handling colour forms is the variety of tools options available to transform thought into

action. The tools are very efficient as they allow you to play with colours, images, layers and

text. The effective use of rectangular and elliptical marquee tools would help you to achieve

the required effects with shapes. Brush, Colourreplacement, Paint Bucket, Magic Wand and

Gradient tools will help you to have control over colours. For removing or editing the images,

colours and shapes, Photoshop provides you with three types of eraser tools and a crop tool.

We, the designers at XEL Web Design, have mastered Photoshop by working on different

types of projects for our clients. We also have brought their ideas and vision to reality

through Photoshop and fulfilled their design needs. So, start exploring the options in

Photoshop and satisfy all your web design needs.

Topic : Project 8: Printing And Publishing

Topic Objective:

 Define and explain the Opening and Printing Images

 Define and explain the Windows 2000/XP

Definition/Overview:

Adobe Photoshop is a powerful image editing program, and can be used to make high quality

prints from image files. This document is divided into two main sections: Photoshop Setup,

and Opening and Printing Images.
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Key Points:

1. Opening and Printing Images

Open the image that you want to print in Photoshop. If the image contains an embedded

profile that differs from your Working Space, a dialog will be displayed asking whether you

want to convert the image to your Working Space. Generally, you should use the embedded

profile. This is shown in Figure 1 below

If the image you are opening does not contain an embedded profile, a dialog will be displayed

asking what you want to do. If you know what color space the image is in, assign a profile,

either the working RGB (if its the same as your default working space shown here as sRGB),

or select a profile from the dropbox. If you dont know what color space the image is in, select

Leave as is (dont color manage). This is shown in Figure 2.

2. Windows 2000/XP

When you are ready to print the image, select Print with Preview from the File menu. A

dialog similar to the one shown in Figure 7 will appear. Select Color Management from the

dropdown box below near the left side of the dialog. Set the Print: to Document (the

document color space will be shown to the right). To color manage the printed output, set the

Options, Color Handling dropdown box to Let Printer Determine Colors.

This will allow Windows ICM to color manage the image data when it is sent to the printer

driver. If you wish to turn off printer color management, set the Color Handling: dropdown

box to No Color Management. If you wish to have Photoshop apply the printer ICMprofile

when sending the image data to the printer driver, set the Color Handling: dropdown box to

Let Photoshop Determine Colors, and select the ICM profile that you wish to use in the

Printer Profile: dropdown box. You can now specify the Rendering Intent via the dropdown

box below the profile name. Normally, you should select Perceptual or Colorimetric for the

rendering intent depending upon your need. Photoshop interacts with Windows and turns off
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Windows ICM so that the profiles are not applied twice. You are now ready to click on the

Print button to send the image to the printer driver for printing on the selected printer.
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